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Installation

1 Minimum system requirements

Operating system 32 bit version of:

= Windows XP Professional SP2
= Windows Vista Business / Enterprise / Ultimate
= Windows 7 Professional / Ultimate / Enterprise

64 bit version of:

= Windows 7 Professional / Ultimate / Enterprise
RAM Windows XP: 2 GB

Windows Vista, Windows 7: 2 GB

Storage capacity Program: 1 GB

Data: 4 GB
USB ports for devices with USB interface (from version USB 1.1)
Screen Resolution 1024 x 768

The windows user must have administrator rights in order to be able to install
the StabNet software.

Additional requirements for the StabNet server (client-server-version Stab-
Net multi):

Operating system 32 bit version of:

= Windows XP Professional SP2

= Windows Vista Business / Enterprise / Ultimate
= Windows 7 Professional / Ultimate / Enterprise
= Windows Server 2003

= Windows Server 2008

= Windows Server 2008 R2

64 bit version of:

= Windows 7 Professional / Ultimate / Enterprise
= Windows Server 2008 R2

Network 10 Mbit/s, stable and permanent

Communication via TCP/IP
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Caution

During a determination data loss may occur when the PC switches over to
the standby mode. In the energy settings of the operating system the
standby mode should therefore be deactivated.

2 Single workplace installation

With the single workplace version StabNet full the workplace and database
will be installed on your computer.

1 Oninserting the CD into the drive of your computer the installation will
be started automatically. If this option is deactivated on your computer,
double click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nonetheless.

Afterwards, click on [Next >].

2 After having read the license agreement for StabNet and accepted it
with [Yes], a window will appear where you can enter the license code.

3 Enter the license code for StabNet full and click on [Next >].

Metrohm StabNet 1.0 Setup E|
License code
Pleaze type in your icense code. n Me'l’rOhm
Licenss code ||
< Back " Mext > l [ Cancel

4 Now confirm the target folder for the StabNet installation with [Next >]
or select a different target folder with [Browse...].

5 In the dialog window Additional installation information you can
define the paths for the database and backup files:
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Metrohm StabNet 1.0 Setup {5_(|

Additional installation information.

Pleasze enter the necessary information n Me'l‘rOhm

for the operation.

@ Ewery user needs readAwrite rights for the specified directaries!

Database path ||E:\F'logramme\Metrohm\StabNet\Data | E]
Defaul backup path ||C:\Plogramme\Metrohm\StabNet\B ackup | B
< Back " Mext > l [ Cancel ]

i

The default paths are different for Windows 2000, Windows XP, Win-
dows Vista and Windows 7.

With the button [Advanced...] the ports StabNet uses to communicate
with the database and administration server can be modified. If the ports
are already used, an appropriate error message will appear. Ask your sys-
tem administrator for more information about this. Continue with [Next
>].

Follow the instructions of the program until the following message
appears:

Metrohm StabNet 1.0 Setup

i If you use a fireswall program please check its settings.
\g StabMNet uses the following ports:
7301, 7502, 5793, 3796

This message points out which ports StabNet uses. Write down these
ports and inform your system administrator in case StabNet is not able to
connect to the database. Confirm the message with [OK].

As soon as the copying procedure has been finished you can set further
workplace settings:



Metrohm StabNet 1.0 Setup

Workplace settings

Pleasze set your client 1D and your n Me'l'rOhm

prefered language.

X

Client ID EK

Language Englizh b

I et ][ Cancel ]

The option This client ID must exist in the current StabNet system
is only selectable if a database from a previous installation already exists
on your computer or if you want to connect to a database server which
has been installed on another computer.

If you activate this option, then StabNet checks whether the identifier
you have entered exists in the database. If this is true the identifier and all
associated settings will be adopted. With this option reinstalling a client is
much easier.

Click on [Next >]. If the database ports are not available, an appropriate
error message will appear and the installation will be canceled. In this
case, check your server and firewall settings before installing the program
again.

8 At the end of the installation, the file info.txt will be created which con-
tains all relevant information concerning your current StabNet installa-
tion. Save this file on your hard disk in case of need in future and print it
(add to 1Q).

0™

An InstallLog file can be found in the installation directory of Stab-
Net under ...bin\InstallLog. It contains a listing of all files copied to
your computer during the installation and a confirmation that the
installation has been successfully completed.

9 Complete the installation with [Finish].
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3 Client/server installation
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With the StabNet multi version (client/server version with 3 licenses) you can
select during the installation whether you want to install a client or the server
(incl. client) on your computer.

If you want to install a client only on your computer, a server, to which the
client will be connected, must have been previously installed on another com-
puter.

1 Oninserting the CD into the drive of your computer the installation will
be started automatically. If this option is deactivated on your computer,
double click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nonetheless.

Afterwards, click on [Next >].

2 After having read the license agreement for StabNet and accepted it
with [Yes], a window will appear where you can enter the license code.

3 Enter the license code for StabNet multi and click on [Next >].

Metrohm StabNet 1.0 Setup E|
Licenze code
Pleasze type in pour license code. n Me‘l’rohm
License code |
< Back " MHext > l [ Cancel

4 Now confirm the target folder for the StabNet installation with [Next >]
or select a different target folder with [Browse...].

5 The dialog window Additional installation information appears
where you can select whether you want to install a client or the server:



Metrohm StabMet 1.0 Setup gl

Additional installation information.
£2. Metrohm

Flease enter the necessany information
far the operation.

(%) Client/S erver
@ Ewvery user needs read/write rights for the specified directories!
Databage path C:AProgrammetetrohm'StabMethD ata [:]
Default backup path C:AProgramme’h etrobmbStabMetsB ackup E]
() Client
[ < Back H Mext > l [ Cancel ]

The option Client/Server installs the client and the database server on
your computer. Select this option if your computer will be used as server.

With Client, only the client will be installed and you have to select the
database server (has to be installed in advance!), to which you want to

connect, with |;|. The network server name or the IP address are accep-
ted.

With the button [Advanced...] the ports StabNet uses to communicate
with the database and administration server can be modified. If the ports
are already used, an appropriate error message will appear. Ask your sys-
tem administrator for more information about this. Continue with [Next
>].

6 All further installation steps correspond to those of the single workplace

installation on from point 6.

4 Modifying / repairing / removing the installation

and upgrading the license

In order to carry out modifications on the current StabNet installation, start
the file setup.exe on the installation CD or click under:

= Windows XP and older - Control Panel » Software
=  Windows Vista / Windows 7 - Control Panel » Programs and Features

on Metrohm StabNet. Then select Change/Remove:
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Modify

Repair/Update

License upgrade

Remove
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Metrohm StabMet 1.0 Setup E|

Willkommen

Programm andern, repaneren, aktualisieren oder entfernen. n Me'mhm

“willkammen beirn % ensaltungsprogramm wvon StabMet, Mit diezem Programm konnen Sie
Anderngen an der aktuellen [nstallation womehmen. 'wahlen Sie eine der unten aufgefuhrten
Optionen aus.
(%) Programm &ndern
ﬁ YW Ehlen Sie neue Programmeigenzchaften aus oder entfernen Sie bereits
inztallierte Eigenschaften.
() Programm reparieren/aktualisiersn
Installieren Sie alle Programmeigenschaften ermewt, die wom vorherigen Setup
installiert wurden.
() Lizenzupgrade
= Meue Lizenz
T

) Programm entfemen

@ Entfermen aller inztallierter Programmeigenschaften.

“Weiter > ] ’Abblechen

With this option you can change the paths to the database and backup files
and set the ports which StabNet uses for communication. With the StabNet
multi version you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically cop-
ied to the new location.

With this option you can repair an existing defective installation or update an
older installation.

= Repairing the installation
In case of a defective StabNet installation because e.g. a DLL file is missing
or a program file has been deleted by mistake, StabNet can be repaired
with this option.

» Updating the installation
In case an older version of StabNet is installed, it will be updated to the
new version of StabNet.

A direct upgrade of your current installation to a StabNet version with addi-
tional features is possible:

= StabNet full to StabNet multi

In order to do this, enter your new license code in the next dialog window.

This option removes your StabNet installation. Data which has been gener-
ated after the installation (e.g. database entries, log files, exported data etc.)
will remain on your hard disk.



5 Programm update with StabNet full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically upda-
ted for further use.

i

The files in the database and backup directory will be retained when updat-
ing the program.

Files in the sub-directories bin, jre, lib, res, doc and examples will be
overwritten by the update. Files in these directories which have not been
overwritten by the update will be deleted. The deleted files are listed in the
InstallLog.

1 Save the configuration database into an external directory using the
backup function of StabNet. In the program part Configuration, select
the menu item File » Backup » Manually. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
carried out. It is recommended to copy the backup file to CD/DVD.

2 |If desired, export the methods in addition to the automatic backup of the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click
on [OK]. The methods are exported into the desired directory. It is recom-
mended to copy the exported methods to CD/DVD.

3 Save all determination databases created by yourself into an external
directory using the backup function of StabNet. In the program part
Database, select the menu item File » Database manager.... Select
the desired database and click on [Backup]. Select the Backup direc-
tory, enter a name for the backup file and click on [Start]. The backup is
carried out. It is recommended to copy the backup file to CD/DVD.

4 Save further files created by yourself in the installation directory (e.g.
export files) into an external directory or to CD/DVD.

5 Close StabNet. Insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next >].
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Metrohm StabNet 1.0 Setup ﬁ_q

Welcome

tdadify, repair, update, or remove the program. n Me'l‘rOhm

“Welcome to the StabMet Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.

(%) Modify
ﬁ Select new program features to add or select curently installed features to
TEMOYE.

() Repair/Update
@ Reinstall all program features installed by the previous setup.

() Licenze upgrade
e Mew licenze
|
() Remove
@ Remave all installed features.

Mext > ][ Cancel

6 Enter your update license code and click on [Next >].

Metrohm StabNet 1.0 Setup E|
License code
Pleaze type in your icense code. n Me'I‘rOhm

License code || ||| ||| ||| ||| ||| |

< Back " Mest > l [ Cancel

7 Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation for a successful installation is saved in the
StabNet installation folder (default: C:\Program Files\Metrohm\StabNet)
under bin\InstallLog.

6 Program update with StabNet multi
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During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the server are automatically updated for further use with the new
version of StabNet multi.



10

i

The files in the database and backup directory will be retained when updat-
ing the program.

Files in the sub-directories bin, jre, lib, res, doc and examples will be
overwritten by the update. Files in these directories which have not been
overwritten by the update will be deleted. The deleted files are listed in the
InstallLog.

1 Make sure StabNet multi is closed on all clients.

i

In the sub-directory bin of the StabNet installation there is the appli-
cation Clients.exe with which all clients and their status can be dis-
played.

2 Open StabNet multi on the server and save the configuration database
into an external directory using the backup function of StabNet. In the
program part Configuration, select the menu item
File » Backup » Manually. Select the Backup directory, enter a name
for the backup file and click on [Start]. The backup is carried out. It is rec-
ommended to copy the backup file to CD/DVD.

3 If desired, export the methods in addition to the automatic backup of the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click
on [OK]. The methods are exported into the desired directory. It is recom-
mended to copy the exported methods to CD/DVD.

4 Save all determination databases on the server into an external directory
using the backup function of StabNet. In the program part Database,
select the menu item File » Database manager.... Select the desired
database and click on [Backup]. Select the Backup directory, enter a
name for the backup file and click on [Start]. The backup is carried out. It
is recommended to copy the backup file to CD/DVD.

5 Save further files created by yourself in the installation directory (e.g.
export files) into an external directory or to CD/DVD.

6 Updating the server

Close StabNet multi on the server and on all clients. Insert the installa-
tion CD on the server and double click the file setup.exe. Then select
Repair/Update and click on [Next >].
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Metrohm StabNet 1.0 Setup {5_(|

Welcome

tdadify, repair, update, or remove the program. n Me'l‘rOh

“Welcome to the StabMet Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.

(%) Modify
ﬁ Select new program features to add or select curently installed features to
TEMOYE.

() Repair/Update
@ Reinstall all program features installed by the previous setup.

() Licenze upgrade
e Mew licenze
|

() Remove
@ Remave all installed features.

Mext > ][ Cancel

7 Enter the update license code for StabNet multi and click on [Next >].

Metrohm StabNet 1.0 Setup E|
License code
Pleaze type in your icense code. n Me'I‘rOhm

License code || ||| ||| ||| ||| ||| |

< Back " Mest > l [ Cancel

8 E Note

The update of StabNet multi consists of the server license and three
client licenses. If an existing installation contains additional licenses,
these will be deleted.

Click on [OK] in the corresponding message in order to continue the
installation.

9 Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to the server
and with a confirmation for a successful installation is saved in the server's
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StabNet installation folder (default: C:\Program Files\Metrohm\StabNet)
under bin\InstallLog.

10 In case additional licenses have been removed during the server update,
or if further additional licenses are to be added, the Administrator can
enter them in StabNet (dialog: Configuration » Tools » Program
administration... » Licenses > Add licenses).

11 Updating clients

For each client, insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next >]. Complete
the installation with [Finish].

n Note

In order to facilitate updating many clients, the installation can be cop-
ied from the CD to a writeable medium and the file stabnet_init.ini
can be modified. There, user-defined parameters (license code, installa-
tion path, server name, etc.) for the installation can be set in advance,
which allows you to only having to click through the installation.

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation for a successful installation is saved in the
client's StabNet installation folder (default: C:\Program Files\Metrohm
\StabNet) under bin\InstallLog.

7 Adding additional licenses with Windows Vista
or newer

General

Since Windows Vista, Microsoft has introduced the UAC (User Account Con-
trol), which permits running tasks either as non-administrator or as administra-
tor (without changes of user, switching off or similar).

http://technet.microsoft.com/en-us/library/cc709691%28WS. 10%29.aspx
http.//technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

This function can, however, cause difficulties with client-server installations of
StabNet.

Problem description

One would like to add additional licenses for the program; the license code for
an additional 5 licenses, for example, is added (on the server) in the program
part Configuration in the dialog window Program administration (accessi-
ble via menu item Tools » Program administration..., tab Licenses).

The file license.mlic, which contains the standard license code and the addi-
tional license codes, is stored in the bin directory of the program installation
(C:\Program Files\Metrohm\StabNet\bin).
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http://technet.microsoft.com/en-us/library/cc709691%28WS.10%29.aspx
http://technet.microsoft.com/en-us/magazine/2007.06.uac.aspx

If one adds the 5 licenses and then looks at this file license.mlic, only the
standard license code will be listed (for 3 licenses).

If one highlights the file license.mlic and presses Compatibility files in the
bar, then one will arrive in the directory C:\Users\'User"\AppData\Local\Vir-
tualStore\Program Files\Metrohm\StabNet\bin (‘User’ being the abbrevi-
ation (UID) for the user logged in on the operating system). The file
license.mlic with the license codes for the standard licenses and the 5 newly
added licenses is to be found here, i.e. the additional licenses are stored in the
VirtualStore only for the Windows user who was logged in on the PC at the
time the additional licenses were added.

On the server, the program recognizes all of the licenses; the operating system
adds the file license.mlic from the directory C:\Users\'User"\AppData\Local
\VirtualStore\Program Files\StabNet\bin to the detail list of the directory
C:\Program Files\Metrohm\StabNet\bin.

For the client-server functionality of the database server, however, the file
license.mlic in the directory C:\Program Files\Metrohm\StabNet\bin is
relevant, and here only the basic license is listed. Therefore, problems are to be
anticipated when adding additional clients (more than the 3 clients present in
the default settings).

Remedy

= For new installations

— To enter additional licenses, the program must be started as adminis-
trator (position the mouse on the Program icon and click the right
mouse button — select Run as administrator there).

— If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\StabNet\bin will contain both license codes.

= For existing installations

— First of all, the file license.mlic in the directory C:\Users
\'User"\AppData\Local\VirtualStore\Program Files\Metrohm
\StabNet\bin must be deleted.

This file must not be present in the VirtualStore of any user —a
check must be made to make sure of this, and any such files which
may be found must be deleted.

— Afterwards, the program must be started as administrator (position
the mouse on the Program icon and click the right mouse button —
select Run as administrator).

If one then adds the license code for additional licenses in the usual
way, then the file license.mlic in the directory C:\Program Files
\Metrohm\StabNet\bin will contain both license codes.

8 User rights for StabNet
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In order that the logged in user be able to access all functions with StabNet,
the windows system administrator must ensure that the permissions are set for
the directories as listed below:
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Directory Permission Group name or
user name

Database directory Modify SYSTEM

Directory where the databases will be saved (...\Data) User

Backup directory Modify User’

Directory where the backups will be stored (...\Backup)

%ALLUSERSPROFILE%\Application Data\Metrohm Modify User

(Windows 2000, Windows XP)**

%PROGRAMDATA%\Metrohm (Windows Vista, Win- Modify User

dows 7) ™

Export directories Modify User”

Directories where the exported files are to be saved.

PDF directories Modify User®

Directories where the PDF files are to be saved.

Desktop Modify User

%PROGRAMFILES%\Metrohm\StabNet Read Execute User”

User = name of the user who is logged in

During installation of StabNet the permission Full Control is set for the following groups: SYS-

TEM, Administrators, User, Guests, Main users.
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